Jak korzystać z Funkcji Wyszukaj Pionowo vLookUp w Excel VBA

1. Jak korzystać z funkcji WYSZUKAJ.PIONOWO w VBA?

Chcesz skorzystać z funkcji wyszukaj pionowo w VBA? VBA w Excelu daje nam możliwość korzystania z funkcji arkuszowych. Szczególnie ważną funkcją jest WYSZUKAJ.PIONOWO(). Odwołując się do funkcji arkuszowych powinniśmy skorzystać z funkcji vLookUp. W celu sprawdzenia działania funkcji stwórzmy dwie proste tabelki w Excelu wg. poniższego wzorca:

Tabela 1:

IDWARTOŚĆ
1dolnośląskie
2mazowieckie
3pomorskie
4śląskie
5podkarpackie
6lubelskie

Tabela 2:

IDWARTOŚĆ
1
4
6

Tabelki wstawmy kolejno do Arkusza1 w komórki A1 i D1.

Excel VBA - wyszukaj pionowo w VBA

Excel VBA – wyszukaj pionowo w VBA

W pierwszej kolejności powinniśmy utworzyć prosty skrypt wypełniający komórkę “E2” wartościami wyszukanymi przy użyciu funkcji. W arkuszu Excel w komórkę “E2” wstawilibyśmy następującą formułę: =WYSZUKAJ.PIONOWO(D2;A:B;2;FAŁSZ). W Edytorze VisualBasic wstawiamy nowy moduł. Moduł powinien zawierać następujący kod z użyciem funkcji arkuszowej:

2. Wyszukaj Pionowo w VBA – jak przeciągnąć formułę?

Teraz jedyne, co powinniśmy zrobić, to zapętlić nasz kod, by wypełnić wszystkie wartości tabeli:

Za pomocą funkcji arkuszowej CountA sprawdziliśmy ile wartości niepustych jest w kolumnie “D”. Tyle też razy pętla zostanie powtórzona. Wypełnianie zaczynamy od wiersza nr 2, gdyż musimy pominąć nagłówki tabel. W ten sposób nasz przykład z użyciem funkcji wyszukaj pionowo w VBA został rozwiązany. Jeśli chcielibyśmy skorzystać z funkcji WYSZUKAJ.POZIOMO() powinniśmy w tym celu analogicznie użyć funkcji hLookUp.

Poniżej plik z przykładem:

Wyszukaj_pionowo_w_excel_vba

2 comments

Leave Comment

Twój adres email nie zostanie opublikowany.